لوگو داده پردازان مدرن
0
هیچ محصولی در سبدخرید نیست.

برای مشاهده لیست علاقه مندی ها وارد شوید!

مشاهده محصولات فروشگاه

آموزش سازگار کردن پوسته قدیمی با نسخه جدید ووکامرس

دسته بندی :وردپرس, ووکامرس
آموزش سازگار کردن پوسته قدیمی با نسخه جدید ووکامرس

قدیمی بودن فایلهای پوسته با ووکامرس

مطمئنا تا به حال پس از آپدیت ووکامرس دیدین که پیغامی مبنی بر قدیمی بودن فایلهای پوسته با ووکامرس می آید. حال چه باید کرد؟
نکته یک) اگر درون سایت شما مشکلی ایجاد نشده و ناسازگاری نمی بینید، از خیر اینکار بگذرید. و آن پیام را نادیده بگیرید.
توصیه من این است که برای راحتی کار، از نرم افزارهای filezila جهت اتقال فایل ها به ftp استفاده کنید. و همچنین از xammp برای آزمایش پوسته درون لوکال استفاده کنید.
اولین کار، که بسیار بسیار مهم است بک آپ از پوشه پوسته می باشد. بدون داشتن بک آپ سراغ مراحل بعد نروید.
جهت بک آپ درون public html و بعد وارد wp-content و سپس درون پوشه themes وارد شوید و فولدر پوسته را درون کامپیوتر خود کپی کنید.

تا اینجای کار رو دوستان بلدن. فقط جهت کسانی نوشتم که شاید مبتدی باشن.

حالا :

سازگار کردن پوسته قدیمی با نسخه جدید ووکامرس

ووکامرس نسخه جدید رو دانلود کرده و اون رو از حالت فشرده باز کنید. و از درون آن، فولدر templates را پیدا کنید.
در فولدرهای پوسته، یک فولدر به نام woocommerce وجود دارد، که همان فایلهای درون فولدر templates دانلود شده می باشند.
حالا باید فایلهای templates رو درون فولدر woocommerce پوسته جایگزین کنید.
ولی سریع دست به کار نشید. و هیچ فایلی رو کپی نکنید. و فکر نکنید که مسئله حل شده . تازه اول راهیم.

حال در وردپرس، به منوی ووکامرس و از آن به وضعیت سیستم بروید. در پایین صفحه قسمت قالبها و بازنویسی قالبها رو نگاه کنید. ناسازگاری در لیست فایلهایی که با قرمز علامتگذاری شده است می باشد.
مثل خط زیر
wp_woo_gomarket/woocommerce/checkout/form-coupon.php نسخه ۱.۶.۴ بروز نیست. نسخه پایه ۲.۲,

حالا شما باید ببینید کجای سایتتون ایراد داره، و مثلا خط بالا مربوط به کوپن می باشد. (اینو باید از نام فایل متوجه شد) اگر قسمت کوپن های سایت مشکل دارد، این فایل رو از پوشه templates ووکامرس دانلود شده، به درون فولدر woocommerce پوسته بریزید.
باقی فایلهای مشخص شده هم همینجور.
و حالا به احتمال ۹۰ درصد مشکل ناسازگاری ووکامرس و پوسته حل شده است.

نکته مهمی که وجود داره اینه که گاهی وقتها، با اینکار، در جایی از پوسته مشکلی بوجود می یاد. برای همین در کپی کردن فایلها دقت کنید و اگه دیدید که فایلی رو که جایگزین کردین مشکلی برای پوسته سایت ایجاد کرد، دوباره فایل قدیمیش رو از بک آپ برگردونیند.
پس در جایگزینی فایلها نهایت دقت رو بکنید و هر حا که دیدید مشکلتون حل شده، دیگه جلوتر نرید و باقی فایلها رو آپدیت نکنید.
چون پوسته از توابع درون بعضی از فایلها استفاده می کنه که ممکنه در فایل جدید نباشن. و باید منتظر نسخه جدید باشید.

موفق باشید.

منبع: تالار گفتمان پرشین اسکریپت

مطالب زیر را حتما بخوانید:

  1. آواتار asalasal گفته؛
    20:48 1396/02/13

    سپاس عالی بود

  2. آواتار الهامالهام گفته؛
    02:05 1397/01/05

    سلام و احترام
    واقعا ازتون ممنونم به خاطر این آموزش عالی. من یه مشکل بزرگ توی قالب سایتم داشتم. (لیست برگه ها در صفحه ی فروشگاه واقعا غیر قابل تحمل بود) حتی تغییر کدها هم نتونست اون رو اصلاح کنه. با آموزش شما قالب رو آپدیت کردم و مشکل حل شد.
    باز هم ممنون و موفق باشید.

  3. آواتار میلادمیلاد گفته؛
    16:19 1397/08/30

    باسلام.من بعد از اپدیت ووکامرس وقتی به ادامه مطلب یه محصول میرم توضیحات و متنی که برای محصولم نوشتم بصورت نصفه میاد.ایا با این راهکار حل میشه؟

    • سایت شما بازدید شد
      محصولی وجود نداشت تا اشکال ذکر شده را بررسی نماییم.

  4. آواتار بهمنبهمن گفته؛
    11:19 1398/03/25

    سلام و عرض ادب
    .
    واقعا ممنون و متشکر از این آموزش شما
    عالی بود
    بی نظیر و فوق العاده
    .
    یک سوال داشتم
    من تمامی مواردی که شما فرمودید رو انجام دادم و تمامی خطاها از بین رفت، فقط این خطا اومد:

    فایل woocommerce.php پوسته شما، نمی تواند الگوی سفارشی woocommerce/archive-product.php را نادیده بگیرد. زیرا woocommerce.php اولویت بالاتری نسبت به archive-product.php دارد. این کار برای جلوگیری از مشکلات نمایش می باشد.

    ممنون میشم کمک کنید این مشکل رو هم حل کنم
    سپاسگزارم

    • سلام وقت شما بخیر
      خوشحالیم که مطلب مفید واقع شده است.
      این اخطار صرفا جمله ی خبری است و فایل woocommerce داره کار خودشو درست انجام میده
      آیا مشکلی در نمایش دارید ؟

  5. آواتار abolfazladnkabolfazladnk گفته؛
    23:25 1398/06/27

    سلام. قالب وبسایت من دیگه آپدیت نمیشه و قدیمیه، میخوام ورژن پی اچ پی سایتم رو از 5.6 به 7.3 ارتقا بدم، اما با ورژن قالب من همخوانی نداره، لطفا راهنماییم کنید یا لینک آموزش مربوطه رو بدید ممنون.

    • سلام
      شما باید با یک برنامه نویس و طراح سایت در ارتباط باشید
      این کار جهت تمام فایل های قالب تخصصی است.

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

لینک کوتاه: